【HDU 6581】[2019 HDU 多校第一場] Vacation (思維,枚舉)

題目

Problem Description

Tom and Jerry are going on a vacation. They are now driving on a one-way road and several cars are in front of them. To be more specific, there are n cars in front of them. The ith car has a length of li, the head of it is si from the stop-line, and its maximum velocity is vi. The car Tom and Jerry are driving is l0 in length, and s0 from the stop-line, with a maximum velocity of v0.
The traffic light has a very long cycle. You can assume that it is always green light. However, since the road is too narrow, no car can get ahead of other cars. Even if your speed can be greater than the car in front of you, you still can only drive at the same speed as the anterior car. But when not affected by the car ahead, the driver will drive at the maximum speed. You can assume that every driver here is very good at driving, so that the distance of adjacent cars can be kept to be 0.
Though Tom and Jerry know that they can pass the stop-line during green light, they still want to know the minimum time they need to pass the stop-line. We say a car passes the stop-line once the head of the car passes it.
Please notice that even after a car passes the stop-line, it still runs on the road, and cannot be overtaken.

Input

This problem contains multiple test cases.
For each test case, the first line contains an integer n (1≤n≤105,∑n≤2×106), the number of cars.
The next three lines each contains n+1 integers, li,si,vi (1≤si,vi,li≤109). It’s guaranteed that si≥si+1+li+1,∀i∈[0,n−1]

Output

For each test case, output one line containing the answer. Your answer will be accepted if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a, and the jury’s answer is b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.
The answer is guaranteed to exist.

Sample Input

1
2 2
7 1
2 1
2
1 2 2
10 7 1
6 2 1

Sample Output

3.5000000000
5.0000000000

Source

2019 Multi-University Training Contest 1

思路

線性做法:
到最後的時候,一定是某車後面堵着剩餘所有的車,那麼影響時間的就只有最前面的這輛車。
於是就枚舉以每輛車速度到達終點的時間,取最大即可。
時間複雜度O(n)O(n)

代碼

#include <bits/stdc++.h>

using namespace std;
const int M = 101010;
long long l[M], s[M], v[M], sum;

int main() {
	int n; double ans;
    while (~scanf("%d", &n)) {
        for (int i = 0; i <= n; i++) scanf("%lld", &l[i]);
        for (int i = 0; i <= n; i++) scanf("%lld", &s[i]);
        for (int i = 0; i <= n; i++) scanf("%lld", &v[i]);
        ans = s[0]*1.0 / v[0]; sum = 0;
        for (int i = 1; i <= n; i++)
            sum += l[i], ans = max((sum+s[i])*1.0 / v[i], ans);
        printf("%.10lf\n", ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章