動態規劃經典入門題目

作爲動態規劃的經典入門題目,就是這道題啦。

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)





Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint


嗯,這道題的思路就非常簡單了,給出關鍵的遞推公式吧:

getmax[i][j]=max(getmax[i+1][j],getmax[i+1][j+1])+graph[i][j]。(從數字金字塔的底部向上遞推)

下面是AC代碼

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100;
int graph[maxn][maxn];
int getmax[maxn][maxn];
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<=i;j++)
		{
			scanf("%d",&graph[i][j]);
		}
	}
	for(int i=0;i<n;i++)
	{
		getmax[n-1][i]=graph[n-1][i];
	}
	for(int i=n-2;i>=0;i--)
	{
		for(int j=0;j<=i;j++)
		{
			getmax[i][j]=max(getmax[i+1][j],getmax[i+1][j+1])+graph[i][j];
		}
		
	}
	printf("%d\n",getmax[0][0]);
	return 0;
	
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章