POJ1651:Multiplication Puzzle(區間DP) -ACM

                                                                 POJ - 1651 Multiplication Puzzle(區間DP)

 

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14252   Accepted: 8751

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

題意:每次從一組數中抽取一個數出來與其左右相鄰兩個數相乘,直到抽到只剩兩個數字,將結果相加。第一個數和最後一個數不能抽。

解題:區間DP模板

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define INF 0x3f3f3f3f;
using namespace std;
int n;
int a[105];
int d[105][105];
int main(){
    memset(a,0,sizeof(a));
    cin>>n;
    int i,j;
    for(i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
    }
    for(i=0;i<=104;i++)
        for(j=0;j<=104;j++)
            d[i][j]=0;
    for(int len=1;len<=n;len++)
    {
        for(i=1,j=i+len+1;j<=n;i++,j++)
        {
            int mi=INF;
            for(int k=i+1;k<j;k++)
            {
                mi=min(mi,d[i][k]+d[k][j]+a[k]*a[i]*a[j]);
            }
            d[i][j]=mi;
        }
    }
    cout<<d[1][n]<<endl;
return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章