九度 题目1444:More is better

九度 题目1444:More is better

原题OJ链接:http://ac.jobdu.com/problem.php?pid=1444

题目描述:

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入:

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出:

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入:

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

样例输出:

4
2

解题思路:

输出并查集中元素个数的最大值;
为了计算每个并查集的元素个数,在每个集合的树根结点记录该集合所包含元素的个数,用数组root[ ] 来记录,在合并时累加被合并两个集合包含的元素个数。

源代码:

#include<iostream>
#include<cstring>
using namespace std;
#define MAX_N 10000005
int Tree[MAX_N];
int root[MAX_N];

int findRoot(int x){
    if(Tree[x]==-1) return x;
    else{
        int tmp=findRoot(Tree[x]);
        Tree[x]=tmp;
        return tmp;
    }
}

int main(){
    int n,A,B;
    while(cin>>n){
        for(int i=0;i<MAX_N;i++){
            Tree[i]=-1;
            root[i]=1;
            /*用root[i]表示以结点i为根的树的结点个数,
            其中保存数据仅当Tree[i]为-1时 
            即该结点为树的根结点时有效*/
        }
        for(int i=0;i<n;i++){
            cin>>A>>B;
            A=findRoot(A);
            B=findRoot(B);
            if(A!=B){
                Tree[A]=B;
                root[B]+=root[A];
                /*合并集合时,将子树的根结点上保存的该集合元素
                个数累加到合并后新树的树根上
                */
            } 
        }

        int count=1;
        for(int i=0;i<MAX_N;i++){
            if(root[i]>count && Tree[i]==-1){
                count=root[i];
            }
        }
        cout<<count<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章