PAT——1030 Travel Plan (30 分)

1030 Travel Plan (30 分)

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

將多條最短路徑記錄下來,利用DFS遍歷每一條路徑,選擇cost最少的即可

#include <iostream>
#include <stdio.h>
#include <vector>
using namespace std;

int n,m,s,destination;
const int inf = 9999999;
vector<vector<int> > pre_city(501);
vector<int> tmp_path, path;
int d[501];
int cost[501][501];
int e[501][501];//map
int visited[501] = {0};

int dis = 0, cost_min = inf;

void input()
{
    cin >> n >> m >> s >> destination;
    for(int i = 0; i < m; i++)
    {
        int x, y, dis, c;
        cin >> x >> y >> dis >> c;
        e[x][y] = e[y][x] = dis;
        cost[x][y] = cost[y][x] = c;
    }
}

void DFS(int start, int des)
{
    tmp_path.push_back(start);
    if(start == des)
    {
        int sum_cost = 0;
        for(int i = tmp_path.size() - 1; i > 0; i--)
        {
            sum_cost += cost[tmp_path[i]][tmp_path[i-1]];
        }
        if(sum_cost < cost_min)
        {
            cost_min = sum_cost;
            path = tmp_path;
        }
        tmp_path.pop_back();
        return;
    }

    for(int i = 0; i < pre_city[start].size(); i++)
        DFS(pre_city[start][i], des);
    tmp_path.pop_back();
}

void dijkstra_path()
{
    //初始化
    for(int i = 0; i < n; i++)
    {
        if(e[s][i] != inf)
        {
            d[i] = e[s][i];
            pre_city[i].push_back(s);
        }
    }
    visited[s] = 1;

    for(int i = 0; i < n; i++)
    {
        int minn = inf, k;
        for(int j = 0; j < n; j++)
        {
            if(!visited[j] && d[j] < minn)
            {
                minn = d[j];
                k = j;
            }
        }
        visited[k] = 1;
        //找邊v
        for(int v = 0; v < n; v++)
        {
            if(!visited[v] && d[k] + e[k][v] < d[v])
            {
                d[v] = d[k] + e[k][v];
                pre_city[v].clear();
                pre_city[v].push_back(k);
            }
            else if(!visited[v] && d[k] + e[k][v] == d[v])
            {
                pre_city[v].push_back(k);
            }
        }
    }
    DFS(destination, s);
}

void output()
{
    for(int i = path.size()-1; i > 0; i--)
    {
        dis += e[path[i]][path[i-1]];
        cout << path[i] << " ";
    }
    cout << path[0] << " " << dis << " " << cost_min;
}

int main()
{
    /*1030 Travel Plan (30 分)*/
    fill(d, d+501, inf);
    fill(cost[0], cost[0]+501*501, inf);
    fill(e[0], e[0]+501*501, inf);

    input();

    dijkstra_path();

    output();

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章