1118 Birds in Forest (25 分)(並查集)

1118 Birds in Forest (25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B1 B2 … BK

where K is the number of birds in this picture, and B**i’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

考察並查集的知識,在K B1 B2 … BK 中B1到Bk之間是相互連接的,我們假設B1與後面K-1個相連。

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <vector>
#include <set>
using namespace std;

int n, k, q;
const int maxn = 1e4+10;

set<int> tree, bird;
int arr[maxn];
int parent[maxn];
int Rank[maxn];

int findParent(int x)
{
    int x_root = x;
    while(parent[x_root] != -1)//注意是它的parent不爲空,而不是它自己不爲空
    {
        x_root = parent[x_root];
    }
    return x_root;
}

int Union(int x, int y)
{
    int x_root = findParent(x);
    int y_root = findParent(y);
    if(x_root != y_root)
    {
        if(Rank[x_root] > Rank[y_root])
            parent[y_root] = x_root;
        else if(Rank[x_root] < Rank[y_root])
            parent[x_root] = y_root;
        else{
            parent[x_root] = y_root;
            Rank[y_root]++;
        }
        return 1;
    }
    return 0;
}

int main()
{
    /*1118 Birds in Forest (25 分)*/
    scanf("%d", &n);
    fill(parent, parent+maxn, -1);
    fill(Rank, Rank+maxn, 0);
    for(int i = 0; i < n; i++)
    {
        cin >> k;
        for(int j = 0; j < k; j++)
        {
            scanf("%d", &arr[j]);
            bird.insert(arr[j]);
        }
        for(int j = 1; j < k; j++)
        {
            Union(arr[0], arr[j]);
        }
    }

    for(set<int>::iterator it = bird.begin(); it != bird.end(); it++)
        tree.insert(findParent((*it)));
    printf("%d %d\n", tree.size(), bird.size());
    scanf("%d", &q);
    for(int i = 0; i < q; i++)
    {
        int x, y;
        scanf("%d %d", &x, &y);
        if(findParent(x) == findParent(y))
        {
            printf("Yes\n");
        }else{
            printf("No\n");
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章