【二分】Base Station Sites @ICPC2017HongKong/upcexam5559

時間限制: 1 Sec 內存限制: 128 MB

5G is the proposed next telecommunications standards beyond the current 4G standards. 5G planning aims at higher capacity than current 4G, allowing a higher density of mobile broadband users, and supporting device-to- device, reliable, and massive wireless communications. A telecommunication company would like to install more base stations to provide better communication for customers. Due to the installation cost and available locations,the company can only install S (2 ≤ S ≤ L) base stations at L (2 ≤ L ≤ 100, 000) candidate locations. Since the base stations work in the same frequency band, they will interfere and cause severe performance degradation. To provide high quality communication experience to customers, the company would like to maximize the distance between the base stations so as to reduce the wireless interference among the base stations. Suppose the L candidate locations are in a straight line at locations P1, P2,…, PL (0 ≤ Pi ≤ 1, 000, 000) and the company wants to install S base stations at the L candidate locations. What is the largest minimum distance among the S base stations?

The input data includes multiple test sets.
Each set starts with a line which specifies L (i.e., the number of candidate locations) and S (i.e., the number of base stations). The next line contains L space-separated integers which represent P1, P2,…, PL.
The input data ends “0 0”.
For each set, you need to output a single line which should be the largest minimum distance among the base stations.

sample input
5 3
2 3 9 6 11
4 3
1 4 9 10
0 0

sample output
4

給你L個點,要你選S個點,要求這些點之間的最小距離最大,輸出這個最大值
二分答案

#define IN_PC() freopen("C:\\Users\\hz\\Desktop\\in.txt","r",stdin)
#define OUT_PC() freopen("C:\\Users\\hz\\Desktop\\out.txt","w",stdout)
#include <bits/stdc++.h>

using namespace std;

const int maxn = 100005;
int L,S,P[maxn];

bool judge(int _val) {
    int ret = 1;
    int las = P[0];
    for(int i = 1; i<L; i++) {
        if(P[i]-las>=_val) {
            ret++;
            las = P[i];
        }
    }
    return ret>=S;
}

int main() {
//    IN_PC();
//    OUT_PC();
    while(scanf("%d%d",&L,&S)&&!(L==0&&S==0)) {
        for(int i=0; i<L; i++) {
            scanf("%d",P+i);
        }
        sort(P,P+L);
        int l = 0,r = 1000005;
        while(l<r) {
            int mid = ((l+r)%2)?((l+r)/2+1):((l+r)/2);
            if(judge(mid))
                l = mid;
            else
                r = mid-1;
        }
        printf("%d\n",(l+r)/2);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章