D - Round Numbers(數位dp)

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive rangeStart.. Finish

Sample Input

2 12

Sample Output

6

題目大意:找出區間內數字轉化爲二進制後符合0的個數比1的個數多的數字的個數

思路概括:數位dp 開一個三維dp數組 dp[pos][num0][num1] 表示的是在第pos位0的個數和1的個數

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<bitset>
#include<cassert>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#define lt k<<1
#define rt k<<1|1
#define lowbit(x) x&(-x)
#define lson l,mid,lt
#define rson mid+1,r,rt
using namespace std;
typedef long long ll;
typedef long double ld;
#define ios ios::sync_with_stdio(false);cin.tie(nullptr);
#define mem(a, b) memset(a, b, sizeof(a))
//#define int ll
const double pi = acos(-1.0);
const double eps = 1e-6;
const ll mod = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const ll INF = 0x3f3f3f3f3f3f3f3f;
const int maxn = 1e5 + 50;
int dp[35][35][35];
int a[35];
int dfs(int pos, int num0, int num1, int limit2, int limit)
{
    if(pos == -1)
    {
        if(num0 >= num1) return 1;
        else return 0;
    }

    if(!limit && !limit2 && dp[pos][num0][num1] != -1) return dp[pos][num0][num1];
    int sum = 0;
    int up;
    if(limit) up = a[pos];
    else up = 1;
    for(int i=0;i<=up;i++)
    {
        if(i && limit2) sum += dfs(pos - 1, 0, 1, limit2 && i==0, limit && i == a[pos]);
        if(i && !limit2) sum += dfs(pos - 1, num0, num1 + 1, limit2 && i==0, limit && i == a[pos]);
        if(!i && limit2) sum += dfs(pos - 1, 0, 0, limit2 && i == 0, limit && i == a[pos]);
        if(!i && !limit2) sum += dfs(pos - 1, num0 + 1, num1, limit2 && i ==0, limit && i == a[pos]);
    }
    if(!limit && !limit2) return dp[pos][num0][num1] = sum;
    return sum;
}
int solve(int x)
{
    int len = 0;
    while(x)
    {
        a[len++] = x & 1;
        x >>= 1;
    }
    return dfs(len - 1, 0, 0, 1, 1);
}
int main()
{
    int s, e;
    mem(dp, -1);
    while(cin >> s >> e)
    {
        cout << solve(e) - solve(s - 1) << endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章