POJ 2346

Lucky tickets

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3484   Accepted: 2294

Description

The public transport administration of Ekaterinburg is anxious about the fact that passengers don't like to pay for passage doing their best to avoid the fee. All the measures that had been taken (hard currency premiums for all of the chiefs, increase in conductors' salaries, reduction of number of buses) were in vain. An advisor especially invited from the Ural State University says that personally he doesn't buy tickets because he rarely comes across the lucky ones (a ticket is lucky if the sum of the first three digits in its number equals to the sum of the last three ones). So, the way out is found — of course, tickets must be numbered in sequence, but the number of digits on a ticket may be changed. Say, if there were only two digits, there would have been ten lucky tickets (with numbers 00, 11, ..., 99). Maybe under the circumstances the ratio of the lucky tickets to the common ones is greater? And what if we take four digits? A huge work has brought the long-awaited result: in this case there will be 670 lucky tickets. But what to do if there are six or more digits? 
So you are to save public transport of our city. Write a program that determines a number of lucky tickets for the given number of digits. By the way, there can't be more than 10 digits on one ticket.

Input

Input contains a positive even integer N not greater than 10. It's an amount of digits in a ticket number.

Output

Output should contain a number of tickets such that the sum of the first N/2 digits is equal to the sum of the second half of digits.

Sample Input

4

Sample Output

670

Source

Ural State University Internal Contest October'2000 Students Session

大致題意:

定義一個位數爲偶數的數爲幸運數當且僅當這個數前一半的部分數字之和等於後一半的數字之和,給出一個n,求出有多少個位數小於n的數是幸運數。

解題思路:

就是求n/2位數有多少種不同的和

1、dp[ i ][ j ]表示爲第 i 位和爲 j 的數有多少

2、ans爲dp[ n/2 ][ 0 ~ n/2*9 ]平方和

代碼:

#include<cstdio>
#include<iostream>
using namespace std;
int dp[6][50];
void init(){
	dp[0][0]=1;
	for(int i=1;i<=5;i++){
		for(int j=0;j<=i*9;j++){
			for(int k=0;k<=9;k++){
				if(j>=k)dp[i][j]+=dp[i-1][j-k];
			}
		}
	}
}
int main(){
	init();
	int n;
	scanf("%d",&n);
	int sum=0;
	for(int i=0;i<=n/2*9;i++){
		sum+=dp[n/2][i]*dp[n/2][i];
	}
	printf("%d\n",sum);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章