poj3579 二分

 

 

如題:http://poj.org/problem?id=3579

 

Median
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4518   Accepted: 1389

Description

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi- Xj∣ (1 ≤ i j N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

Source

 

 

 

思路:對於所有的組合一共C(n,2)種,不可能一一枚舉,因此二分C(x):當前x作爲中位數偏大?如果偏大,在左邊找,否則,在右邊找。

對a數組排序,對於a[i],如果>=a[i]+x的個數<=C(n,2)/2,則偏大注意相等時也是偏大,因爲中位數落在了右側區間。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 100005
#define max(a,b)(a>b?a:b)
int a[MAXN];


int C(int x,int n)
{
 int cnt=0;
 int i;
 for(i=0;i<n;i++)
 {
  cnt+=a+n-lower_bound(a+i,a+n,x+a[i]);
 }
 return cnt<=n*(n-1)/4;
}

int main()
{
 //freopen("C:\\1.txt","r",stdin);
 int n;
 while(cin>>n)
 {
  int i;
  int l=0,r=0;
  for(i=0;i<n;i++)
  {
   scanf("%d",&a[i]);
   r=max(r,a[i]);
  }
  sort(a,a+n);
  while(r-l>1)
  {
   int mid=(l+r)/2;
   if(C(mid,n))
    r=mid;
   else
    l=mid;
  }
  cout<<l<<endl;
 }
 return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章