2016SDAU課程練習一1008 Problem I

Problem B
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 147   Accepted Submission(s) : 42
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
2 1 3
 大意就是切木頭,第一個要1min準備時間,下一根如果l和w任意一個小於前一根就要重新準備,求最短時間。
典型的貪心,現在感覺這種傳統的貪心題做起來越來越得心應手了,感覺貪心不難,難的是1、對數據排序2、處理數據,這道題本來想的是直接全排好序,然後直接判斷 ,但是發現難以實現,因爲兩組數據無法同時排序,只能優先一組,於是選擇排一組,算一組。
AC代碼:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<algorithm>
using namespace std;
struct wood{
    int l;
    int w;
}woods[5010];
int num[5050];
bool cmp(const wood &a,const wood &b){
    if(a.l!=b.l)
        return a.l>b.l;
    else
        return a.w>b.w;
}
int main(){
    int m,n,min;
    cin>>m;
    for(int i=0;i<m;i++){
        cin>>n;
        for(int k=0;k<n;k++){
            cin>>woods[k].l>>woods[k].w;
            num[k]=0;
        }
        sort(woods,woods+n,cmp);
        int sum=0;
  for(int k=0;k<n;k++){
   if(num[k])
                continue;
   min=woods[k].w;
   for(int j=k+1;j<n;j++)
   {
    if(min>=woods[j].w && !num[j])
    {
     min=woods[j].w;
     num[j]=1;
    }
   }
            sum++;
        }
        cout<<sum<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章