POJ-2524Ubiquitous Religions(并查集)

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended.
题意分析:n个同学,编号从1到n,在给你m组同学的编号,每组编号表示这两个同学信仰同一个宗教,问所有同学信仰不同宗教的个数,并查集的简单模板题。
AC代码如下:

#include<stdio.h>
int f[50100],n,m;
void inint()
{
	int i;
	for(i=1;i<=n;i++)//初始化每位同学的父亲是自己
		f[i]=i;
	return;	
}
int getf(int v)
{
	if(f[v]==v)
		return v;
	else
	{
		f[v]=getf(f[v]);
		return f[v];
	}
}
void merge(int v,int u)
{
	int t1,t2;
	t1=getf(v);
	t2=getf(u);
	if(t1!=t2)
		f[t2]=t1;
	return ;
}
int main()
{
	int i,x,y,sum,k=1;
	while(scanf("%d%d",&n,&m),n!=0||m!=0)
	{
		sum=0;
		inint();
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			merge(x,y);//合并种类数
		}
		for(i=1;i<=n;i++)
		{
			if(f[i]==i)
				sum++;
		}
		printf("Case %d: %d\n",k++,sum);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章