【hdu2594】Simpsons’ Hidden Talents——KMP

題目:

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5599    Accepted Submission(s): 2025


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
clinton homer riemann marjorie
 

Sample Output
0 rie 3
 

Source

描述:給兩個字符串s1,s2,求2的前綴是1的後綴的最大長度

題解:把兩個字符串拼在一起求一遍nxt數組就行了,但要注意長度不能超過兩個字符串的最小長度

代碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1e5+10;
char text[maxn], pattern[maxn];
int nxt[maxn];
int main()
{
	//freopen("input.txt", "r", stdin);
	while (scanf("%s",text)!=EOF)
	{
		scanf("%s", pattern);
		int len1 = min(strlen(text), strlen(pattern));
		strcat(text, pattern);
		int len = strlen(text);
		for (int i = 0, j = -1; i <= len; i++, j++)
		{
			nxt[i] = j;
			while (~j && text[i] != text[j])
				j = nxt[j];
		}
		for (int i = 0; i < nxt[len] && i < len1; i++)
		{
			printf("%c", text[i]);
			if (i == nxt[len] - 1 || i == len1 - 1)
				printf(" ");
		}
		printf("%d\n", min(nxt[len], len1));       //attention
		memset(text, 0, sizeof(text));
		memset(pattern, 0, sizeof(pattern));
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章