01揹包+完全揹包 HDU - 5410 


Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M
M
Won(currency unit).
At the shop, there are N
N
kinds of presents.
It costs Wi
Wi
Won to buy one present of i
i
-th kind. (So it costs k
k
× Wi
Wi
Won to buy k
k
of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi
Ai × x + Bi
candies if she buys x
x
(x
x
>0) presents of i
i
-th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T
T
≤ 20
1 ≤ M
M
≤ 2000
1 ≤ N
N
≤ 1000
0 ≤ Ai, Bi
Ai, Bi
≤ 2000
1 ≤ Wi
Wi
≤ 2000

Input

There are multiple test cases. The first line of input contains an integer T
T
, indicating the number of test cases. For each test case:
The first line contains two integers M
M
and N
N
.
Then N
N
lines follow, i
i
-th line contains three space separated integers Wi
Wi
, Ai
Ai
and Bi
Bi
.

Output

For each test case, output the maximum candies she can gain.

Sample Input

1
100 2
10 2 1
20 1 1

Sample Output

21




Hint

CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.




#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <map>
#include <queue>
#include <set>
#include <algorithm>
#define LL long long
#define MAX 2005
using namespace std;
int dp[MAX];
int w[MAX],a[MAX],b[MAX];
int t,m,n;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        for(int i=1;i<=n;i++)
            scanf("%d%d%d",&w[i],&a[i],&b[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=m;j>=w[i];j--)
        {
            dp[j]=max(dp[j],dp[j-w[i]]+a[i]+b[i]);   //先通過01揹包來確定拿不拿這件商品的最大價值
        }
        for(int i=1;i<=n;i++)
            for(int j=w[i];j<=m;j++)
        {
            dp[j]=max(dp[j],dp[j-w[i]]+a[i]);  //用完全揹包計算拿了x件商品的最大價值(a[i]*x+b[i])
        }
        printf("%d\n",dp[m]);
    }


    return 0;
}

/*題意:
有M多的錢 去買n種商品
每種商品的價格爲w  如果你買x個這種商品 你會得到 a*x+b個糖果
問最多能得到多少糖果*/

/*思路:
對於每件商品 你如果買一件 那麼你會得到a+b個糖果
如果再次基礎上每一次的購買你就只能得到a個糖果
所以可以看所這種商品有兩種價值
第一種價值只有一次 用01揹包解決
第二種價值可以無限次購買 用完全揹包解決 */



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章