Fractal POJ - 2083 (遞歸打印圖形)

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales. 
A box fractal is defined as below : 

  • A box fractal of degree 1 is simply 
  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)


Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-

思路:

代碼:

 


import java.util.Scanner;

public class Main {
	      static char map[][]=new char[800][800];
	      public static void dfs(int n,int x,int y){
	    	  if(n==1){
	    		  map[x][y]='X';
	    		  return;
	    	  }
              //ans的計算自己找規律
	    	  int ans=1;
	    	  for(int i=1;i<n-1;i++) ans*=3;
	    	  dfs(n-1,x,y);//左上角
	    	  dfs(n-1,x,y+(ans<<1));//右上角
	    	  dfs(n-1,x+(ans<<1),y);//左下角
	    	  dfs(n-1,x+(ans<<1),y+(ans<<1));//右下角
	    	  dfs(n-1,x+ans,y+ans);//中間
	      }
	      public static void main(String[] args) {
			    Scanner scan=new Scanner(System.in);
			    while(scan.hasNext()){
			    	int n=scan.nextInt();
			    	if(n==-1) break;
                    //ans的計算自己找規律
			    	int ans=1;
			    	for(int i=1;i<n;i++) ans*=3;
			    	for(int i=0;i<ans;i++)
			    		for(int j=0;j<ans;j++)
			    			map[i][j]=' ';
			    	dfs(n,0,0);
			    	for(int i=0;i<ans;i++){
			    		 for(int j=0;j<ans;j++)
			    			 System.out.print(map[i][j]);
			    		 System.out.println();
			    	}
			    	System.out.println("-");
			    }
		}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章