A Bug's Life poj 2492

A Bug's Life
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 35131   Accepted: 11526

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

這個題題意就是:

例題一

有3個人,三個"情侶",讓你觀察有沒有同性戀的蟲子


和poj1703題一樣,那裏是兩個集團,這裏只兩個性別,

代碼如下:

#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;

int b[3006], a[3006];

int find(int x)
{
    if ( b[x] == x )
        return x;
    int temp = b[x];
    b[x] = find(b[x]);
    a[x] = a[x]^a[temp];
    return b[x];
}

bool meget( int x, int y )
{
    int fx = find(x);
    int fy = find(y);
    if ( fx == fy )
    {
        if ( a[x] == a[y] )
            return true;
        return false;
    }
    b[fx] = fy;
    a[fx] = !(a[x]^a[y]);
    return false;
}

int main()
{
    int n, m, i, j;
    int T, x, y;
    scanf ( "%d", &T );
    for ( j = 1;j <= T; j++ )
    {
        int temp = 0;
        scanf ( "%d %d", &n, &m );
        for ( i = 1;i <= n; i++ )
        {
            b[i] = i;
            a[i] = 0;
        }
        for ( i = 0;i < m; i++ )
        {
            scanf ( "%d %d", &x, &y );
            if ( meget(x, y) )
                temp = 1;
        }
        printf ( "Scenario #%d:\n", j );
        if ( temp )
            printf ( "Suspicious bugs found!\n\n" );
        else
            printf ( "No suspicious bugs found!\n\n" );
    }
}


代碼菜鳥,如有錯誤,請多包涵!!!

如有幫助記得支持我一下,謝謝!!!

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章