PAT甲級1053題解 以及C++嵌套容器的排序

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight Wi​​ assigned to each tree node T​i. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2^​30​, the given weight number. The next line contains N positive numbers where Wi​(<1000) corresponds to the tree node T​i. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note:

sequence {A1​​ ,A2​ ,⋯,A​n} is said to be greater than sequence {B​1​​ ,B​2​​ ,⋯,B​m​​ } if there exists 1≤k<min{n,m} such that A​i​​ =B​i​​ for i=1,⋯,k, and A​k+1​​ >B​k+1​​ .

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

題解

這題思路還是比較明顯的,對樹進行存儲之後用dfs或者bfs都是可以做的,相對來講應該是遞歸dfs好理解一些,寫起來也更方便,這裏我就是用dfs寫的;

#include <iostream>
#include<vector>
#include<algorithm>
using namespace std;
long long int tempw;
int m, n, w;//m節點總數,n非葉子節點的個數,w給定的權重
struct Node{
	vector<int> child;
	int weight;
}node[110];
vector<int> path;
vector<vector<int> > totalp;
bool cmp(const vector<int> &a,const vector<int> &b){
//容器可以直接進行比較,如果逐個元素去比較會報錯
	return a > b;
}
void dfs(int now,int w) {//now當前節點下標;w是距離需要的weight還有多少的差值
	if (node[now].weight > w)return;//再往下已經不會有滿足條件的解 直接返回進行剪枝
	else if (node[now].weight == w) {
		if (node[now].child.size() != 0)return;
		//當前路徑權重和滿足條件但是不是葉子節點的需要捨去
		path.push_back(node[now].weight);
		totalp.push_back(path);
		path.pop_back();
		return;
	}
	else {
		for (int i = 0; i < node[now].child.size(); i++) {
			path.push_back(node[now].weight);
			dfs(node[now].child[i], w - node[now].weight);
			path.pop_back();
		}
	}
}
int main(){
	int key, childnum, ch;
	cin >> m >> n >> w;
	for (int i = 0; i < m; i++) { cin >> node[i].weight; }
	for (int i = 0; i < n; i++) {
		cin >> key >> childnum;
		for (int j = 0; j < childnum; j++) {
			cin >> ch; node[key].child.push_back(ch);
		}
	}
	dfs(0, w);
	//sort(totalp.begin(), totalp.end(), cmp);//如果要使用cmp函數,就用這個
	sort(totalp.begin(), totalp.end());//默認排序方式是從小打到進行排序
	for (int p = totalp.size() - 1;p>=0; p--) {
		for (int i = 0; i < totalp[p].size(); i++) {
			printf("%s%d", i == 0 ? "" : " ", totalp[p][i]);
		}cout << endl;
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章