【PAT】1080. Graduate Admission (30)

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8

1 4

題意:

(1)分數分爲Ge和Gi兩部分,按照總分給學生排名次,如果總分一樣,則按照Ge來排;

(2)每個學生都有幾個志願,按照志願高低給學生分配學校;

(3)對於名次一樣又報了同一學校的學生,該學校只要接收了一個就得接收全部,即便超出了原定的招生名額;

這道題還是比較簡單明瞭的。

#include <iostream>
#include <vector>
#include <stack>
#include <algorithm>
using namespace std;

struct applicant{
	int id;
	int ge, gi;
	double total;
	int rank;
	vector<int> choices;
};

struct school{
	int quota;
	vector<applicant> app;
};

bool cmp(applicant a, applicant b){ 	
	if(a.total != b.total){
		return a.total>b.total;
	}else if(a.ge!=b.ge){
		return a.ge>b.ge;
	}else{
		return a.id<b.id;
	}
}

bool cmpById(applicant a, applicant b){
	return a.id<b.id;
}

int main(int argc, char** argv) {
	int appNum, schNum, choNum, i;
	scanf("%d%d%d",&appNum,&schNum,&choNum);
	vector<school> sch(schNum);
	for(i=0; i<schNum; i++){
		scanf("%d",&sch[i].quota);
	}
	vector<applicant> app(appNum);
	for(i=0; i<appNum; i++){
		scanf("%d%d", &app[i].ge,&app[i].gi);
		app[i].total = (app[i].ge+app[i].gi)/2.0;
		int c;
		for(int j=0; j<choNum; j++){
			scanf("%d",&c);
			app[i].id = i;
			app[i].choices.push_back(c);
		}
	}
	sort(app.begin(), app.end(), cmp);
	int rank=1, total, ge;
	total = app[0].total;
	ge = app[0].ge; 
	for(i=0; i<app.size(); i++){
		if(app[i].total==total && app[i].ge==ge){
			app[i].rank = rank;
		}else{
			app[i].rank = ++rank;
			total = app[i].total;
			ge = app[i].ge;
		}
	}
	
 	for(i=0; i<app.size(); i++){
 		applicant tmp = app[i];
		for(int t=0; t<tmp.choices.size(); t++){
			int u = tmp.choices[t];
		 	if(sch[u].app.size()<sch[u].quota || sch[u].app.back().rank==tmp.rank){
		 		sch[u].app.push_back(tmp);	
		 		break;
			}
		} 	
	}
 
	for(i=0; i<schNum; i++){
		if(sch[i].app.size()==0){
			cout<<endl;
			continue;
		}	
		sort(sch[i].app.begin(), sch[i].app.end(), cmpById);
		for(int t=0; t<sch[i].app.size(); t++){
			if(t==sch[i].app.size()-1){
				printf("%d\n",sch[i].app[t].id);
			}else{
				printf("%d ",sch[i].app[t].id);
			}
		}
	}	
	return 0;
}







發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章