PAT甲級1144 The Missing Number (20分) 簡單題

1144 The Missing Number (20分)
Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
​5
​​ ). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:
Print in a line the smallest positive integer that is missing from the input list.

Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7

簡單題,因爲Int最大值太大了,不好直接開一個大數組,用mapp搞定

#include <iostream>
#include <algorithm>
#include <unordered_map>
#include <vector>
using namespace std;
int main()
{
    int N;
    cin>> N;
    unordered_map<int,int> mapp;
    for(int i=0;i<N;i++){
        int num;
        cin>>num;
        mapp[num]=1;
    }
    int pos=1;
    while(mapp[pos]==1){
        pos++;
    }
    cout<<pos;

    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章