PAT甲級1149 Dangerous Goods Packaging (25分) 和乙級1090 危險品裝箱 (25分) 盡力簡化思路減少時間

1149 Dangerous Goods Packaging (25分)
When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化劑) must not be packed with flammable liquid (易燃液體), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10
​4
​​ ), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:
For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:
6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
Sample Output:
No
Yes
Yes

這題給出的兩兩不匹配的貨物ID ,所以不能用並查集,因爲貨物是兩兩不匹配的,比如20001 20003 可以共存的,但在並查集二者就是一個集合了,並不適用。

  • 題目也說給出的不匹配貨物對 最多10^4 對,而且一個id可能對應幾種不匹配的貨物,感覺麻煩,所以還是把不匹配對保存起來,對後面給出的貨物列表處理
  • 不匹配對子保存的話,每個id有個vector 或者set,都行,vector插入塊查找滿,set插入慢查找快,記錄不匹配的貨物。
  • 對於給出的貨物列表,需要好好考慮,別使用每個貨物id 和之前的貨物的所有不匹配id進行比較,很慢,這樣做的的話,其實第一個貨物的不匹配集合被訪問了好多次了,很慢 測試點2過不去的
  • 最好就是把貨物列表記錄中的id保存下來,使用sign[100000]={0} id存在就賦值爲1,然後從頭開始訪問貨物列表中每個元素的不匹配id,sign[id]==1就是有不匹配的,這樣每個貨物列表的不匹配貨物id 就訪問了一次,速度很快

代碼


#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <map>
#include <cmath>
#include <unordered_set>
using namespace std;

int main()
{
    int n,m;
    cin>>m>>n;


    vector<unordered_set<int>> mapp(100000);

    for(int i=0; i<m; i++)
    {
        int a,b;
        cin>>a>>b;
        mapp[a].insert(b);
        mapp[b].insert(a);
    }
    for(int i=0; i<n; i++)
    {
        int k;
        cin>>k;
        int sn[k];
        int has[100000]={0};
        for(int q=0; q<k; q++)
        {
            int ll;
            cin>>ll;
            has[ll]=1;//記錄貨物列表的id
            sn[q]=ll;
        }
        int out=1;
        for(int q=0; q<k&&out==1; q++)
        {
            int num=sn[q];
            for(auto  p=mapp[num].begin(); p!=mapp[num].end(); p++)
            {

                int maodun=*p;
                if(has[maodun]==1)
                {
                    out=0;
                    break;
                }
            }
        }
        if(out==1)
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章