PAT甲级1133 Splitting A Linked List (25分) 简单题 ,list删除

1133 Splitting A Linked List (25分)
Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤10
​3
​​ ). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer in [−10
​5
​​ ,10
​5
​​ ], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:
For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
Sample Output:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

就是给了一个链表,按照负数调在前面,0-K 在中的 顺序调整,我第一想法是构建一个lsit< node > 然后再这个list表先提取负数,再提取0-k之间的数,剩下的顺序不变

几个关键的点

  • 如何保存输入给的结点信息,我是用了两个map 映射,根据pos 映射对应的data和next,也可以直接使用一个node数组,都行

    struct node {
        int data, next;
    }list[100000];
    
  • 如何将保存的结点信息构造出来,我是用的list< node > ,看了别人的代码感觉更好的办法是建立三个vector< node > 根据data小于0 大于0小于K 大于K 分别保存,这样提取时候也简单,如果使用list 的提取就需要进行三次,每次提取之后使用erase(it++) 删除对应的结点


#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <unordered_map>
#include <list>
using namespace std;
struct node
{
    int posl;
    int data;
    int next;

};

int main()
{
    int pos,N,K;
    cin>>pos>>N>>K;
    vector<node> nodeSave;
    unordered_map<int,int> map_data;
    unordered_map<int,int> map_next;

    for(int i=0; i<N; i++)
    {
        node a;
        cin>>a.posl>>a.data>>a.next;
        map_data[a.posl]=a.data;
        map_next[a.posl]=a.next;
    }

    list<node> listt;
    while(pos!=-1)
    {
        node a;
        a.posl=pos;
        a.data=map_data[pos];
        a.next=map_next[pos];
        pos=a.next;
        listt.push_back(a);
    }
    vector<node> out;
    for(auto it=listt.begin(); it!=listt.end();)
    {
       // cout<<(*it).posl<<' '<<(*it).data<<endl;
        if((*it).data<0)
        {
            out.push_back(*it);
            listt.erase(it++);// 后面的++很关键
        }
        else
            it++;
    }
    for(auto it=listt.begin(); it!=listt.end();)
    {
       // cout<<(*it).posl<<' '<<(*it).data<<endl;
        if((*it).data<=K)
        {
            out.push_back(*it);
            listt.erase(it++);// 后面的++很关键
        }
        else
            it++;
    }
    for(auto it=listt.begin(); it!=listt.end();it++)
    {

            out.push_back(*it);

    }
    //cout<<out[0].posl;
    for(int i=0;i<out.size();i++){
        if(i==0){
            printf("%05d %d ",out[i].posl,out[i].data);
        }
        else{
            printf("%05d\n%05d %d ",out[i].posl,out[i].posl,out[i].data);

        }
    }
    cout<<-1;
    return 0;
}


更好办法柳神:https://blog.csdn.net/liuchuo/article/details/78037305

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章