PAT甲級1116 Come on! Lets C (20分) prime素數

1116 Come on! Let’s C (20分)
“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

0、 The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
1、 Those who ranked as a prime number will receive the best award – the Minions (小黃人)!
2、 Everyone else will receive chocolates.
Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
​4
​​ ), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:
For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
Sample Output:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

感覺常規題,就是實現一個素數判斷的問題

#include <iostream>
#include <math.h>
#include <unordered_map>
using namespace std;

int isPrime(int pos)
{

    for(int i=2; i<=sqrt(pos); i++)
    {
        if(pos%i==0)
        {
            return 0;
        }
    }

    return  1;
}
int main()
{
    int N;
    cin>>N;
    unordered_map<int,int> mapp;
    for(int i=1; i<=N; i++)
    {
        int num;
        cin>>num;
        mapp[num]=i;
    }
    int M;
    cin>>M;
    int searchSign[10000]= {0};
    for(int i=1; i<=M; i++)
    {
        int searchNumber;
        cin>>searchNumber;
        if(mapp[searchNumber]==0)
        {
             printf("%04d",searchNumber);
           cout<<": Are you kidding?"<<endl;
        }
        else
        {
            if(searchSign[searchNumber]==1)
            {
                printf("%04d",searchNumber);
                cout<<": Checked"<<endl;
            }
            else
            {
                searchSign[searchNumber]=1;
                int pos=mapp[searchNumber];
                if(pos==1)
                {
                    printf("%04d",searchNumber);
                    cout<<": Mystery Award"<<endl;
                }
                else if(isPrime(pos))
                {
                    printf("%04d",searchNumber);
                    cout<<": Minion"<<endl;
                }
                else
                {
                    printf("%04d",searchNumber);
                    cout<<": Chocolate"<<endl;
                }
            }
        }
    }


    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章