PAT甲級1155 Heap Paths (30分) 深搜

1155 Heap Paths (30分)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap1155 Heap Paths (30分)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

也是普通的深搜,只是加了條件限制:

  • 規定了深搜的序列,先右後左,這個完全可以在深搜調用時候先搜索右孩子再左孩子很好弄
  • 讓你判斷是否是葉子節點,我是判斷結點超過二叉樹數組最後一個元素了沒有
  • 大堆 小堆的判斷問題,這部分邏輯我還是捋了捋,我的想法是用ismax ismin還分別記錄是大堆還是小堆,然後實現兩個函數判斷輸出的數列是遞增還是遞減

代碼如下

#include <iostream>
#include <algorithm>
using namespace std;
#include <vector>


vector<int> vec;
vector<int> out;
int isMax=1;
int isMin=1;
int Maxsign()
{
    int sign=1;//大堆
    for(int i=0; i<out.size()-1; i++)
    {
        if(out[i]<out[i+1])
        {
            sign=0;
            break;
        }
    }
    if(sign==1)
        return 1;
    else
        return 0;
}
int Minsign()
{
    int sign=1;//小堆
    for(int i=0; i<out.size()-1; i++)
    {
        if(out[i]>out[i+1])
        {
            sign=0;
            break;
        }
    }
    if(sign==1)
        return 1;
    else
        return 0;
}
void df(int pos)
{
    int num=vec.size();
    num--;//就是下標小於等於num的都是存在的
    if(pos*2+1<=num)
    {
        //左右孩子都搜索,先右孩子
        out.push_back(vec[pos*2+1]);
        df(pos*2+1);
        out.pop_back();

        out.push_back(vec[pos*2]);
        df(pos*2);
        out.pop_back();
    }
    else if(pos*2==num)
    {
        //只有左孩子了
        out.push_back(vec[pos*2]);
        df(pos*2);
        out.pop_back();
    }
    else
    {
        //葉子節點了
        //判斷out裏面的元素是什麼順序
        for(int i=0;i<out.size();i++){
            if(i==0)
                cout<<out[i];
            else
                cout<<' '<<out[i];
        }
        cout<<endl;


        if(isMax)
            isMax=Maxsign();
        if(isMin)
            isMin=Minsign();
    }

}
int main()
{
    int N;//0到N-1  根節點是0
    cin>>N;
    vec.push_back(-1);
    for(int i=0; i<N; i++)
    {
        int num;
        cin>>num;
        vec.push_back(num);
    }
    out.push_back(vec[1]);
    df(1);
    if(isMax)
        cout<<"Max Heap";
    else if(isMin)
        cout<<"Min Heap";
    else
        cout<<"Not Heap";

    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章