hdu 5059 Help him

Help him

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 480    Accepted Submission(s): 119


Problem Description
As you know, when you want to hack someone's program, you must submit your test data. However sometimes you will submit invalid data, so we need a data checker to check your data. Now small W has prepared a problem for BC, but he is too busy to write the data checker. Please help him to write a data check which judges whether the input is an integer ranged from a to b (inclusive).
Note: a string represents a valid integer when it follows below rules.
1. When it represents a non-negative integer, it contains only digits without leading zeros.
2. When it represents a negative integer, it contains exact one negative sign ('-') followed by digits without leading zeros and there are no characters before '-'.
3. Otherwise it is not a valid integer.
 

Input
Multi test cases (about 100), every case occupies two lines, the first line contain a string which represents the input string, then second line contains a and b separated by space. Process to the end of file.

Length of string is no more than 100.
The string may contain any characters other than '\n','\r'.
-1000000000$\leq a \leq b \leq 1000000000$
 

Output
For each case output "YES" (without quote) when the string is an integer ranged from a to b, otherwise output "NO" (without quote).
 

Sample Input
10 -100 100 1a0 -100 100
 

Sample Output
YES NO
 

Source
 


題解及代碼:


       題意很簡單,給一個字符串,和一個區間,看這個字符串能否構成一個合法的整數,並且其值是否在這個區間內(注意-0爲非法數據)。

       首先直接排除-和-0的情況,然後判斷前導0的情況,再判斷0-9以外字符的情況,接着看其長度是否大於12,最後把它轉化成整數,判斷大小。

     

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
typedef long long ll;


bool judge(char s[],ll a,ll b)
{
    ll num=0,d=1,i=0;
    int len=strlen(s),k=0;
    if(s[0]=='-') d=-1,k++;
    if(k==len||s[0]=='-'&&s[k]=='0') return false;
    for(i=k;i<len-1;i++)
    if(s[i]!='0') break;

    if(i!=k) return false;
    for(int i=k;i<len;i++)
    if(s[i]<'0'||s[i]>'9') return false;

    for(int i=k;i<len;i++)
    {
        num=num*10+s[i]-'0';
        if(i-k>11) return false;
    }
    //printf("%I64d\n",num*d);
    if(num*d<a||num*d>b)  return false;
    return true;
}

int main()
{
    ll a,b;
    char s[110];
    while(gets(s)!=NULL)
    {
       scanf("%I64d%I64d",&a,&b);
       if(a>b) swap(a,b);

       if(judge(s,a,b)) printf("YES\n");
       else printf("NO\n");
       getchar();
    }
    return 0;
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章