PAT (Basic Level) Practice 1044 火星数字 (20分)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13


 




-代码如下 

#include <iostream>
#include <string>
using namespace std;
string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {"###", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string s;
int len;

void fun1(int num) {
	if (num / 13) cout << b[num/13];
	if (num / 13 && num % 13) cout << " ";
	if (num % 13 || num == 0) cout << a[num%13];
}

void fun2() {
	if (s == "tret") {
		cout << 0;
		return ;
	}
	int t1 = 0, t2 = 0;
	string s1, s2;
	s1 = s.substr(0, 3); //获得字符串s中 从第0位开始的长度为3的字符串
	if (len > 4) s2 = s.substr(4, 3);
	for(int i = 1; i < 13; i++)
	{
		if (s1 == b[i]) t1 = i;
		if (s1 == a[i] || s2 == a[i]) t2 = i;
	}
	cout << t1 * 13 + t2;
}

int main()
{
	int n;
	cin >> n;
	getchar();
	for(int i = 0; i < n; i++)
	{
		getline(cin,s);
		if (s[0] >= '0' && s[0] <= '9') {
			fun1(stoi(s));
		} else {
			len = s.size();
			fun2();
		}
		cout << endl;
	}
	
	return 0;
}

结果

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章