Stars POJ - 2352 二維偏序問題CDQ分治

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

題意:給你n個點的座標,該點的等級爲除其本身外所有橫縱座標都不大於該點的點的個數,輸出0~n-1等級各有多少點。

#include<map>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=15010;
int ans[maxn],res[maxn],n;
struct node{
	int a;
	int b;
	int id;
}a[maxn],tmp[maxn];
bool cmp(node x,node y)
{
	if(x.b!=y.b) return x.b<y.b;
	else return x.a<y.a;
}
void cdq(int l,int r)
{
	if(l==r) return ;
	int mid=(l+r)>>1;
	cdq(l,mid);cdq(mid+1,r);
	int p=l,q=mid+1,cnt=l-1;
	while(p<=mid&&q<=r)
	{
		if(a[p].a<=a[q].a) tmp[++cnt]=a[p++];
		if(a[p].a>a[q].a) ans[a[q].id]+=p-l,tmp[++cnt]=a[q++];
	}
	while(p<=mid) tmp[++cnt]=a[p++];
	while(q<=r) ans[a[q].id]+=mid-l+1,tmp[++cnt]=a[q++];
	for(int i=l;i<=r;i++) a[i]=tmp[i];
}
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++) scanf("%d%d",&a[i].a,&a[i].b),a[i].id=i;
	sort(a+1,a+1+n,cmp);
	cdq(1,n);
	for(int i=1;i<=n;i++) res[ans[i]]++;
	for(int i=0;i<n;i++) printf("%d\n",res[i]);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章