POJ1125(FLoyed)

POJ1125


Stockbroker Grapevine

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

題意

​ 股票經紀人要在一羣人中散佈一個謠言,而謠言只能在親密的人中傳遞,給出了人與人之間的關係及傳遞謠言所用的時間,要求程序給出應以那個人爲起點,可以在最短的時間內讓所有的人都得知這個謠言。要注意從a到b傳遞的時間不一定等於從b到a的時間,如果沒有方案能夠讓每一個人都知道謠言,則輸出"disjoint"。

​ 輸入第一行,代表總人數n。n=0結束。接着有n行,第i+1行代表第i個人的關係,其中第一數子t表示於t個人關係要好,接下來是t對數字,每對數字的第一個數字j表示i與j要好,第二個數字表示謠言從i到j所用的時間。

​ 輸出爲2個數字,第一個數字爲謠言的起點。第二個是所用的時間。

思路

有向圖的最短路徑,使用FLoyed算法。

使用Dijkstra算法也可求解,時間複雜度是一致的。

代碼

public class StockbrokerGrapevine {
  private static final int inf = 9999999;   // 最大值


  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);

    while (true) {
      int n = sc.nextInt();
      if (n == 0) {
        break;
      }
      int[][] graph = new int[105][105];
      for (int i = 0; i <= 104; i++) {
        for (int j = 0; j <= 104; j++) {
          if (i == j) {
            graph[i][j] = 0;
          } else {
            graph[i][j] = StockbrokerGrapevine.inf;
          }
        }
      }
      for (int j = 1; j <= n; j++) {
        int m = sc.nextInt();//第i個人與m個人要好。
        for (int k = 0; k < m; k++) {
          int num = sc.nextInt();//第i個人與第num個人要好
          int minute = sc.nextInt();//第i個人與第num個人要好,花費時間爲minute
          graph[j][num] = minute;
        }
      }


      for (int i = 1; i <= n; i++) {//  floyd。
        for (int j = 1; j <= n; j++) {
          for (int k = 1; k <= n; k++) {
            if (graph[j][i] + graph[i][k] < graph[j][k]) {
              graph[j][k] = graph[j][i] + graph[i][k];
            }
          }
        }
      }

      int stockbroker = 0;//以第i個stockbroker爲起點的所用最少時間。
      int time = StockbrokerGrapevine.inf;//謠言傳遞時間。
      for (int i = 1; i <= n; i++) {
        int sum = 0;
        for (int j = 1; j <= n; j++) {
          if (i != j && graph[i][j] > sum) {
            sum = graph[i][j];
          }
        }
        if (time > sum) {
          stockbroker = i;
          time = sum;
        }
      }
      System.out.println(stockbroker + " " + time);
    }
  }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章