Largest prime factor(素数筛选法)

Largest prime factor
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6950 Accepted Submission(s): 2122

Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

Input
Each line will contain one integer n(0 < n < 1000000).

Output
Output the LPF(n).

Sample Input

1
2
3
4
5

Sample Output

0
1
2
1
3

//这里用了素数筛选法 这里一开始想打表 可是一看数据规模为一百万 如果还用之前的打表 那么肯定会超时的 所以这里采用了筛选法 一个数为素数那么他的倍数一定不是一个素数 即合数 2 是素数 那么2的倍数都不是素数 3 是素数 6,9,。。。3*n 肯定也都不是素数了 那么他的最大质因数就是3 的最大质因数 此时这种效率就非常的高了

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
int prime[3000007];
int indx = 0;
void dabiao()
{
    prime[1] = 0;
    for(long i =2;i<=3000000;i++)
    {
        if(prime[i]==0)//只有prime为0 那么他才是一个素数
        {
            prime[i] = ++indx;
            for(long j = i+i ;j<=1000000;j+=i)//筛选素数的倍数
                prime[j] = prime[i];
        }
    }
}
int main()
{
    dabiao();
    long tt;
    while(~scanf("%ld",&tt))
    {
        printf("%ld\n",prime[tt]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章