POJ Expanding Rods 1905 (二分)

Expanding Rods
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 15285   Accepted: 4071

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

Source


推出来公式算不出来,算不出来就枚举答案,由于题目说的扩张不会超过L的一半,所以在  [ 0 , L/2  ] 这个区间找答案


这是推出两个公式

r=(L*L+4*h*h) / (8*h)

S= 2*r*arcsin(L/2/r)


二分出的答案,带入上面两个公式,算出S'与题目中L'=(1+n*C)*L比较


#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
using namespace std;
#define esp 1e-6
double s,n,c,mid;
void erfen(double l,double r)
{
    if(r-l>=esp)
    {
        mid=l+(r-l)/2;
        double r=(s*s+4*mid*mid)/8/mid;
        double ss=2*asin(s/2/r)*r;
        if(ss>(1+n*c)*s)
        {
            erfen(l,mid);
        }
        else
        {
            erfen(mid,r);
        }
    }
}
int main()
{
    double l,r;
    while(~scanf("%lf%lf%lf",&s,&n,&c))
    {
        if(s==-1 && n==-1 && c==-1)
            break;
        l=0.00;
        r=s/2;
        erfen(l,r);
        printf("%.3f\n",mid);
    }

    return 0;
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章