PAT (Advanced Level) Practice 1025 PAT Ranking (25分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 解題思路:
1、先對一個考場的學生排序,再排名;

2、對所考場的學生排序,再排名;

實現代碼:

#include<iostream>
#include<string>
#include<algorithm>
#define MAX 30000
using namespace std;
typedef struct {
	string id;
	int gr;
	int fr;
	int ln;
	int lr;
}people;
people p[MAX];
bool cmp(people p1, people p2) {
	if (p1.gr > p2.gr)
		return true;
	else if (p1.gr == p2.gr)
		return p1.id < p2.id;
	else
		return false;
}
void lsort(int beg, int end) {//一個考場的學生排名
	int count = 0,rank=1;
	int i = beg, j = end;
	for (; i < j; i++) {
		p[i].lr = rank;
		if (p[i].gr != p[i + 1].gr)
			rank = count + 2;
		count++;
		if (count == end - beg)
			return;
	}
}
void fsort(int m) {//所有的考試排名
	int count = 0, rank = 1;
	for (int i = 0; i < m; i++) {
		p[i].fr = rank;
		if (p[i].gr != p[i+1].gr)
			rank = count + 2;
		count++;
		if (count == m)
			return;
	}
}
int main(void) {
	int n,k,m=0,gr;
	string id;
	cin >> n;
	for (int i = 0, j = 0; i < n; i++) {
		cin >> k;
		m += k;
		for (; j < m; j++) {
			cin >> id >> gr;
			p[j].id = id;
			p[j].gr = gr;
			p[j].ln = i + 1;
		}
		sort(p + m - k, p + m, cmp);
		lsort(m - k, m);
	}
	sort(p, p + m,cmp);
	fsort(m);
	cout << m << endl;
	for (int i = 0; i < m; i++) 
		cout << p[i].id << " " << p[i].fr << " " << p[i].ln << " " << p[i].lr << endl;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章