HDU - 3709 : Balanced Number (數位dp)

題目鏈接 : HDU-3709

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].
InputThe input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18). OutputFor each case, print the number of balanced numbers in the range [x, y] in a line. Sample Input
2
0 9
7604 24324
Sample Output
10
897
題意:計算從l到r有多少個平衡數。即從該數的某一位分開,兩邊的權值相等。

題解:記錄的時候注意記錄兩邊的權值差值~不然數組會炸掉~


#include<stdio.h>
#include<iostream>
#include<set>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<queue>
#include<vector>
using namespace std;
#define ll long long
const int inf = 0x3f3f3f3f;

ll dp[20][20][3600];
int digt[20];
ll dfs(int pos , int mid , int sub , bool limit) {
    if(pos < 0)
        return sub == 0;
    if(!limit && dp[pos][mid][sub] != -1)
        return dp[pos][mid][sub];
    int prepos = limit ? digt[pos] : 9;
    ll ans =0 ;
    for(int i = 0 ; i <= prepos ; i ++) {
        ans += dfs(pos - 1 , mid , sub + (pos - mid)*i , limit&&i == prepos);
    }
    if(!limit)
        dp[pos][mid][sub] = ans;
    return ans;
}
ll solve(ll x) {
    memset(digt , 0 , sizeof(digt));
    int k = 0 ;
    while(x) {
        digt[k++] = x % 10;
        x /= 10;
    }
    ll ans = 0 ;
    for(int i = 0 ; i < k ; i ++) {
        ans += dfs(k - 1 , i , 0 , 1);
    }
    return ans - k;
}
int main()
{
    //freopen("in.txt" , "r", stdin);
    ll l , r ;
    int t ;
    memset(dp , -1 , sizeof(dp));
    scanf("%d" , &t);
    while(t--) {
        scanf("%lld %lld" , &l , &r) ;
        printf("%lld\n" , solve(r) - solve(l - 1));
    }
    return 0;
}









發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章