POJ-3641:Pseudoprime numbers

題目:

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output

no no yes no yes yes


概譯:費馬定理覺得所有的素數p都是,給定一個大於1小於p的a, a的p次冪模p的值爲a。然後有一些不是素數的p對於某些a也有同樣的性質,我們就叫他基於a 的Pseudoprime(a從1到p都成立的就叫Carmichael number啦,別的題裏大家應該見過)。現在給一些組p和a,判斷一下是不是Pseudoprime number。

題目很水,只是藉機留下幾個基礎的模板。詳見代碼:

#include<iostream>
#include<cstdio>
#include<cmath>

using namespace std;

bool isprime(int n)//試除法判定素數 
{
	int m=floor(sqrt(n)+0.5);
	//這裏sqrt應該都懂……+0.5是避免浮點數誤差,因爲下面枚舉時舉i<=m的,所以不要緊 
	//如果不用變量m而是直接把sqrt寫循環裏,那會導致每次都計算一遍sqrt,會增加時間 
	for(int i=2;i<=m;i++)
		if(n%i==0)
			return false;
	return n>1;//最後濾去0和1 
}
int qmul(int a,int b,int mod)//快速乘,類似於快速冪 
{
	int ans=0;
	while(b)
	{
		if(b&1)
			ans=(ans+a)%mod;
		b>>=1;
		a=a*2%mod;
	}
	return ans;
}
int qpow(int a,int n,int mod)//快速冪,自己在紙上隨便列兩個數寫一遍就懂了 
{
	int res=1;
	while(n)
	{
		if(n&1)
			res=qmul(res,a,mod)%mod;//原型爲res=res*a%mod,這裏沒用longlong怕爆 
		n>>=1;
		a=qmul(a,a,mod)%mod;//原型爲a=a*a%mod 
	}
	return res;
}
int main()
{
	int p,a;
	
	while(~scanf("%d%d",&p,&a)&&p|a)
		printf("%s\n",a==qpow(a,p,p)&&!isprime(p)?"yes":"no");

	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章