HDU 5775 Bubble Sort(逆序對)

Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input
2
3
3 1 2
3
1 2 3

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

求出逆序對算一算最大能達到的左右距離之差就好了,寫法不一,這裏用線段樹求逆序對。

最右位置:每個值右邊有多少個比其小的值,加上原位置得到;
最左位置:初始位置和最終位置較小的那個。

ac代碼:

#include <bits/stdc++.h>

using namespace std;

#define rep(i,a,n) for(int i = (a); i < (n); i++)
#define per(i,a,n) for(int i = (n)-1; i >= a; i--)
#define clr(arr,val) memset(arr,val,sizeof(arr))
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define pi acos(-1)
typedef long long LL;
typedef pair<int, int> pii;
const double eps = 1e-8;
const int maxn = 100005;
int segtree[maxn<<2];
int a[maxn<<1], b[maxn<<1];
void pushup(int n){
    segtree[n] = segtree[n<<1] + segtree[n<<1|1];
}
void update(int v, int l, int r, int num){
    if(l == r && l == num){
        segtree[v] = 1;
        return;
    }
    int mid = (l+r)>>1;
    if(num > mid) update(v<<1|1, mid+1, r, num);
    else update(v<<1, l, mid, num);
    pushup(v);
}
int get(int l, int r, int v, int le, int ri)
{
    int res=0;
    if(l >= le && r <= ri)
        return segtree[v];
    int mid = (l+r)>>1;
    if(mid >= le) res += get(l, mid, v<<1, le, ri);
    if(mid < ri) res += get(mid+1, r, v<<1|1, le, ri);
    return res;
}
int main(int argc, char const *argv[]) {
    int t, n;
    cin >> t;
    int cas = 1,tmp;
    while (t--) {
        clr(segtree,0);
        scanf("%d",&n);
        rep(i, 1, n+1) {
            scanf("%d", &tmp);
            a[tmp] = i;
        }
        rep(i, 1, n+1) {
            b[i] = get(1,n,1,a[i],n);
            update(1,1,n,a[i]);
        }
        printf("Case #%d:",cas++);
        rep(i, 1, n+1)
            printf(" %d", abs(min(i, a[i]) - max(i, a[i]+b[i])));
        puts("");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章