POJ-1961(Period)(kmp())

POJ-1961(Period)(kmp())

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

題意:在前i個字符中,循環節出現的次數(要求循環節出現的次數要大於1),比如aabaabaabaab,在前兩個字符中a出現了兩次,循環節爲a。在前6個字符中,循環節出現了2次,循環節爲aab,在前9個字符中,循環節出現了3次,循環節爲aab;在12個字符中循環節出現了4次,循環節爲aab。

My solution:

/*2016.4.11*/

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char c[1000100];
int nest[1000100],n;
void getnest()
{
	int i,j,k=0,t;
	i=0;j=-1;
	nest[i]=j;
	while(i<n)
	{
		if(j==-1||c[i]==c[j])
		{
			i++;
			j++;
			t=i-j;//求循環節長度 
			if(j&&i%t==0)//注意j不能等於0,否則循環節出現的次數爲1,即:循環節爲前i個字符.(不符題意) 
			{
			//	k=1;
				printf("%d %d\n",i,i/t);
			}
			nest[i]=j;
		}
		else
		j=nest[j];
	}
//	if(k==0)
//	printf("0 0\n");//題中所給的測試數據都能找到循環節,因此不用考慮不存在的情況 
}
int main()
{
	int i=0,j,k,m;
	while(scanf("%d",&n)==1&&n)
	{
		i++;
		if(i!=1)//注意格式 
		printf("\n");
		scanf("%s",c);
		printf("Test case #%d\n",i);
		getnest();
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章