POJ-2406(Power Strings)(KMP())

POJ-2406(Power Strings)(KMP())

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed. 

注:這題主要是找最小循環節。而最小循環節長度爲:len-nest(len)(即;len-j (j爲getnest中跳出循環後,j的值))

做完這道題可以再做一下poj1961

My  solution:

/*2016..4.11*/

#include<cstring>
#include<cstdio>
char c[1001000];
int nest[1001000];
void getnest()
{
	int i=0,j=-1,k,len,h;
	len=strlen(c);
	nest[i]=j;
	while(i<len)
	{
		if(j==-1||c[i]==c[j])
		{
			i++;
			j++;
			nest[i]=j;
		}
		else
		j=nest[j];	
	}
	k=i-j;//k爲最小循環節長度 
	if(i%k==0)
	{
		h=i/k;//最小循環節個數 
		printf("%d\n",h);
	}	
}
int main()
{
	int i,j,k;
	while(scanf("%s",c)!=EOF)
	{
		if(c[0]=='.')
		break;
		getnest();
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章