hdu--1060--Leftmost Digit

Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17741 Accepted Submission(s): 6854

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4

Sample Output

2
2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


需要用到科學記數法和對數運算的知識。
我們把num*num的值記作:num*num=a*10^n,其中1

附上ac代碼:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;
typedef long long ll;

int main()
{
    int t;

    scanf ("%d",&t);

    while (t--)
    {
        ll n;
        int i,j;
        double x;

        scanf ("%lld",&n);
        x = n*log10(n*(1.0));
        x -= (ll)x;

        int a = pow(10.0,x);

        printf ("%d\n",a);

    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章