hdu 3635 Dragon Balls

Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

基礎並查集

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#define maxn 11000
int pre[maxn];
int cnt[maxn];
using namespace std;
int findroot(int num)
{
    while(pre[num] != num)
    {
        num = pre[num];
    }
    return pre[num];
}
int main()
{
    int t;
    scanf("%d",&t);
    int k = 1;
    while(t--)
    {
        int n,q;
        scanf("%d%d",&n,&q);
        printf("Case %d:\n",k++);
        for(int i = 1; i <= n; i++)
        {
            pre[i] = i;
            cnt[i] = 1;
        }
        for(int i = 0; i < q; i++)
        {
            char c;
            scanf(" %c",&c);
            if(c == 'T')
            {
                int a,b;
                scanf("%d%d",&a,&b);
                int roota = findroot(a);
                int rootb = findroot(b);
                if(roota != rootb)
                {
                    pre[roota] = rootb;
                    cnt[rootb] += cnt[roota];
                }
            }
            if(c == 'Q')
            {
                int a;
                scanf("%d",&a);
                int times = 0;
                while(pre[a] != a)
                {
                    a = pre[a];
                    times++;
                }
                printf("%d %d %d\n",findroot(a),cnt[findroot(a)],times);
            }
        }
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章