poj 2828 Buy Tickets

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 21428 Accepted: 10496
Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output

77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

題意: 不停的給你一個位置和這個位置的值,求最後這個序列

做法:線段樹 從最後一個開始(因爲最後一個的位置肯定是不變的),線段樹存的是區間內剩餘的空位,每次更新時先訪問左兒子,如果左兒子的值大於等於要插入的位置,就繼續,否則訪問右兒子。

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#define LL long long
int pos[210000],val[210000];
int ans[210000];
int tree[4*210000];
using namespace std;
void build(int p,int l,int r)
{
    if(l == r)
    {
        tree[p] = 1;
        return;
    }
    int mid = (l + r) >> 1;
    build(p*2,l,mid);
    build(p*2+1,mid+1,r);
    tree[p] = tree[p*2] + tree[p*2+1];
}
int update(int p,int l,int r,int num)
{
    tree[p]--;
    if(l == r)
        return l;
    int mid = (l + r) >> 1;
    if(tree[p*2] >= num)
        return update(p*2,l,mid,num);
    else
        return update(p*2+1,mid+1,r,num-tree[p*2]);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(tree,0,sizeof(tree));
        memset(ans,0,sizeof(ans));
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d",&pos[i],&val[i]);
        }
        build(1,1,n);
        for(int i = n-1; i >= 0; i--)
        {
            int temp = update(1,1,n,pos[i]+1);
            ans[temp] = val[i];
        }
        for(int i = 1; i <= n; i++)
        {
            if(i != n) printf("%d ",ans[i]);
            else     printf("%d\n",ans[i]);
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章