poj 1679 The Unique MST

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32373 Accepted: 11743
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
1. V’ = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output

3
Not Unique!

題意:給你一個圖,判斷其最小生成樹是否唯一

求其次小生成樹,如果次小生成樹與最小生成樹總權值相同,則說明不唯一,否則唯一

次小生成樹求法:先用prime求出最小生成樹,在求的過程中記錄下來從點i到點j路徑中最大的那條邊的權值,然後再枚舉沒在最小生成樹中的邊,進行替換最小生成樹中的邊,如果能替換並且替換之後權值不變則不唯一。(現學現賣)

#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
#define maxn 1100
#define INF 999999999
int edge[maxn][maxn];
bool vis[maxn];
int lowcost[maxn];
bool used[maxn][maxn];
int Max[maxn][maxn];
int pre[maxn];
using namespace std;
int n,m;
int prime(int num)
{
    memset(used,0,sizeof(used));
    memset(Max,0,sizeof(Max));
    vis[num] = 1;
    pre[num] = -1;
    for(int i = 1; i <= n; i++)
    {
        if(i == num) continue;
        lowcost[i] = edge[i][num];
        pre[i] =num;
    }
    int sum = 0;
    for(int i = 1; i < n; i++)
    {
        int minn = INF;
        int temp;
        for(int j = 1;j <= n; j++)
        {
            if(vis[j] == 0 && lowcost[j] < minn)
            {
                minn = lowcost[j];
                temp = j;
            }
        }
        if(minn == INF) return -1;
        vis[temp] = 1;
        sum += minn;
        used[temp][pre[temp]] = used[pre[temp]][temp] = 1;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j] == 1)
            {
                Max[j][temp] = Max[temp][j] = max(Max[j][pre[temp]],lowcost[temp]);
            }
            if(vis[j] == 0 && lowcost[j] > edge[j][temp])
            {
                lowcost[j] = edge[j][temp];
                pre[j] = temp;
            }
        }
    }
    return sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(vis,0,sizeof(vis));
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                edge[i][j] = INF;
            }
        }
        for(int i = 0; i < m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            edge[u][v] = edge[v][u] = w;
        }
        int ans = prime(1);
        if(ans == -1)
        {
            printf("Not Unique!\n");
            continue;
        }
        int Min = INF;
        for(int i = 1; i <= n; i++)
        {
            for(int j =i+1; j <= n; j++)
            {
                if(edge[i][j] != INF && !used[i][j])
                {
                    Min = min(Min,ans+edge[i][j]-Max[i][j]);
                }
            }
        }
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                printf("%d ",Max[i][j]);
            }
            printf("\n");
        }
        if(Min == ans) printf("Not Unique!\n");
        else printf("%d\n",ans);
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章