hdu 3371 Connect the Cities

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21416 Accepted Submission(s): 5079

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output
1

Author
dandelion

把連在一起的城市之間的距離看成0,然後最小生成樹,注意兩點之間可能存在重邊,存最小的就好了

#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
#define LL long long
#define INF 999999999
const int maxn = 1100;
int edge[maxn][maxn];
int lowcost[maxn];
bool vis[maxn];
int n,m,k;
using namespace std;
int prime(int num)
{
    vis[num] = 1;
    int sum = 0;
    for(int i = 1; i <= n; i++)
    {
        lowcost[i] = edge[i][num];
    }
    for(int i = 1; i < n; i++)
    {
        int  minn = INF;
        int temp;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j] == 0 && lowcost[j] < minn)
            {
                minn = lowcost[j];
                temp = j;
            }
        }
        if(minn == INF) return -1;
        vis[temp] = 1;
        sum += minn;
        for(int j = 1; j <= n;j++)
        {
            if(vis[j] == 0 && lowcost[j] > edge[temp][j])
            {
                lowcost[j] = edge[temp][j];
            }
        }
    }
    return sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(vis,0,sizeof(vis));
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                edge[i][j] = INF;
            }
        }
        for(int i = 0; i < m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            if(w < edge[u][v])
            edge[u][v] = edge[v][u] = w;
        }
        for(int i = 0; i < k; i++)
        {
            int nn;
            int a[510];
            scanf("%d",&nn);
            for(int j = 0; j < nn; j++)
            {
                scanf("%d",&a[j]);
            }
            for(int z = 0; z < nn; z++)
            {
                for(int j = z+1; j < nn; j++)
                {
                    edge[a[z]][a[j]] = edge[a[j]][a[z]] = 0;
                }
            }
        }
        int ans = prime(1);
        printf("%d\n",ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章