hdu 1222



Description

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input

2 1 2 2 2
 

Sample Output

NO YES
題意:
一個山圍繞着n個洞,編號依次爲0,1,2,...n-1,狼先從第一個洞開始尋找兔子,然後每隔m個洞尋找,依次循環,如果到最後每隔洞都被狼找了一遍,那麼兔子是不安全的,要輸出NO,否則輸出YES。
思路:
求出n,m的最大公約數,如果兩個數的最大公約數爲1,那麼每個洞都會被狼搜尋到,應該輸出NO,否則輸出YES。
代碼:
#include<cstdio>
using namespace std;
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int P,m,n;
    scanf("%d",&P);
    while(P--)
    {
        scanf("%d%d",&m,&n);
        if(gcd(m,n)==1)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章