Fibonacci————矩陣快速冪求斐波那契數列

題目:

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 

題意:

給一個數n,讓求斐波那契數列的第n項的後四位;

 

思路:

因爲n可以很大,所以利用矩陣快速冪求;

 

代碼:

 

#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<math.h>
#include<queue>
#include<map>
#include<stack>
#include<string>
#include<algorithm>
#define ll long long
#define N 1008611
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
    ll a[5][5];
};
node solve(node x,node y)//兩矩陣相乘
{
    node ans;
    memset(ans.a,0,sizeof(ans.a));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                ans.a[i][k]+=x.a[i][j]*y.a[j][k]%10000;
                ans.a[i][k]%=10000;
            }
        }
    }
    return ans;
}
node quicklymod(node s,ll n)//矩陣快速冪
{
    node ans;
    ans.a[0][0]=1;ans.a[0][1]=0;
    ans.a[1][0]=0;ans.a[1][1]=1;//單位矩陣
    while(n)
    {
        if(n&1)
            ans=solve(s,ans);
        s=solve(s,s);
        n>>=1;
    }
    return ans;
}
int main()
{
    ll n;
    while(~scanf("%lld",&n)&&n!=-1)
    {
        if(n==0)
        {
            printf("0\n");
            continue;
        }
        node s;
        s.a[0][0]=1;s.a[0][1]=1;
        s.a[1][0]=1;s.a[1][1]=0;
        node ans=quicklymod(s,n-1);
        printf("%lld\n",ans.a[0][0]);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章