LightOJ - 1007 Mathematically Hard (歐拉打表+前綴和)

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input

Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237

Note

Euler's totient function  applied to a positive integer n is defined to be the number of positive integers less than or equal to n that are relatively prime to n is read "phi of n."

Given the general prime factorization of , one can compute  using the formula

題意:求區間a~b的歐拉函數的平方和。

套用求歐拉函數的模板

void init()
{
    for(int i=1;i<=N;i++)
        f[i]=i;
    for(int i=2;i<=N;i++)
    {
        if(f[i]==i)
        {
            for(int j=i;j<=N;j+=i)
                f[j]=f[j]/i*(i-1);
        }
    }
}

打表存歐拉函數,在用前綴和儲存,注意開數組範圍需要開 unsigned long long

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef unsigned long long ll;
const int INF=0x3f3f3f3f;
const int N=5000000;
ll f[5000100];
void init()
{
    for(int i=1;i<=N;i++)
        f[i]=i;
    for(int i=2;i<=N;i++)
    {
        if(f[i]==i)
        {
            for(int j=i;j<=N;j+=i)
                f[j]=f[j]/i*(i-1);
        }
    }
}
void he()
{
    for(int i=2;i<=N;i++)
        f[i]=f[i-1]+f[i]*f[i];
}
int main()
{
    int t,k=1;
    init();
    he();
    scanf("%d",&t);
    while(t--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("Case %d: %llu\n",k++,f[b]-f[a-1]);
    }
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章