【Dijkstra】PAT 1003. Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the meantime, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

 

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

 

#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn = 510;
int weight[maxn];
int e[maxn][maxn];
const int inf = 99999999;
int dis[maxn];
int num[maxn];
bool visited[maxn];
int N, M, c1, c2;
int w[maxn];
int main(){
    scanf("%d%d%d%d", &N, &M, &c1, &c2);
    for(int i = 0; i < N; i++){
        scanf("%d", &weight[i]);
    }
    fill(e[0], e[0]+maxn*maxn, inf);
    fill(dis, dis+maxn, inf);
    int fr, to, wt;
    for(int i = 0; i < M; i++){
        scanf("%d%d%d", &fr, &to, &wt);
        e[fr][to] = e[to][fr] = wt;
    }
    //dijieskra
    dis[c1] = 0;
    num[c1] = 1;
    w[c1] = weight[c1];
    for(int i = 0; i < N; i++){
        int u = -1;
        int mind = inf;
        for(int j = 0; j < N; j++){
            if(!visited[j] && dis[j] < mind){
                mind = dis[j];
                u = j;
            }
        }
        if(u == -1) break;
        visited[u] = true;
        for(int v = 0; v < N; v++){
            if(!visited[v] && e[u][v] != inf){
                if(dis[u] + e[u][v] < dis[v]){
                    dis[v] = dis[u] + e[u][v];
                    num[v] = num[u];
                    w[v] = w[u] + weight[v];
                }
                else if(dis[u] + e[u][v] == dis[v]){
                    num[v] += num[u];
                    if(w[u] + weight[v] > w[v]){
                        w[v] = w[u] + weight[v];
                    }
                }
            }
        }
    }
    printf("%d %d", num[c2], w[c2]);

}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章