PTA-1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

題意:輸出和最大的子序列的和,其子序列的第一個元素和最後一個元素。當序列的所有元素都是負數的時候,輸出的和爲0

解析:暴力尋找和最大的子序列。

樣例給的有點坑,輸出的是元素,不是下標

#include<iostream>
#include<cstring>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define maxn 100005
#define inf 0x80000000
int a[maxn];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 0; i < n; i ++)
        scanf("%d",&a[i]);
    int indexi = 0,indexj = 0;
    int temp = 0;
    int sum = inf;
    for(int i = 0; i < n; i ++)
    {
        for(int j = i ; j < n; j ++)
        {
            temp += a[j];
            if(temp>sum)
            {
                sum = temp;
                indexi = i;
                indexj = j;
            }
        }
        temp = 0;
    }
    int maxx = inf;
    for(int i = 0; i < n; i ++)
    {
        maxx = max(maxx,a[i]);
    }
    if(maxx<0)
      {
          sum = 0;
          indexi = 0;
          indexj = n-1;
      }
    printf("%d %d %d",sum,a[indexi],a[indexj]);

}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章