FatMouse' Trade(經典貪心)

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 109942    Accepted Submission(s): 37886


 

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

 

Sample Input


 

5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1

 

 

Sample Output


 

13.333 31.500

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
	double x,y,z;
}num[1001];
int compare(node x,node y)
{
	return x.z>y.z;//運用結構體變量存儲
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		double sum=0;
		if(n==-1&&m==-1)
		{
			break;
		}
		for(int i=0;i<m;i++)
		{
			scanf("%lf%lf",&num[i].x,&num[i].y);
			num[i].z=num[i].x/num[i].y;
		}
		sort(num,num+m,compare);//用結構體中的c變量的大小進行排序,注意這個是從大到小進行!
		for(int i=0;i<m;i++)
		{
			if(n>num[i].y)//當n大於整體的時
			{
				sum+=num[i].x;
				n-=num[i].y;
			}
			else        //當n不能整體換時!,取比例 
			{
				sum+=(n*num[i].x)/num[i].y;
				break;
			}
		}
		printf("%.3lf\n",sum);
	}
	return 0;
 } 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章