HDU - 2955 Robberies(花費和價值交換的揹包問題)

Robberies

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 

                                                                                      


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<queue>
#include<set>
#include<algorithm>
#define sc(x) scanf("%d",&x)
#define scc(x,y) scanf("%d%d",&x,&y)
#define scll(x) scanf("%lld",&x)
#define mem(x,a) memset(x,a,sizeof x)
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
typedef pair<int ,int> PII;

const int maxn = 10005;

double dp[maxn];
double c[maxn];
int w[maxn];

double m;
int n;

int main(){
    int t;
    sc(t);
    while(t--){
        scanf("%lf%d",&m,&n);
        m=1.0-m;
        int sum=0;
        for(int i=0;i<n;i++){
            scanf("%d%lf",&w[i],&c[i]);
            c[i] = 1.0-c[i];    // 不被抓的概率---當物品
            sum += w[i];        // 總共的錢---當做包
        }
        mem(dp,0);
        dp[0]=1;    // 一分錢也沒搶的時候,不被抓的概率爲1
        for(int i=0;i<n;i++){
            for(int j=sum;j>=w[i];j--){
                dp[j] = max(dp[j],dp[j-w[i]]*c[i]);
            }
        }
        // 錢多向錢少找,一旦發現不被抓的概率大於等於給定的值,輸出當前的錢,錢越多不被抓的概率越低
        for(int i=sum;i>=0;i--){    
            if(dp[i]>=m){
                printf("%d\n",i);break;
            }
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章