poj 3280 區間dp

B - Cheapest Palindrome

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

 

我們先看樣例 abcb

1.可以去掉一個a 或者在尾部加一個a 最小值爲1000

2.變成bcbabcb 或者 去掉bcb變成a 

假設我們的樣例變成:

3 4
abcb
a 1000 1100
b 700 350
c 200 800

其實我們花費沒有變,但是字符串變了 變成了 cac

我們可以發現不管是加上還是減去都可以使其變成一個迴文串,所以這個是一個干擾項。加上一個和減去一個其實是相同的操作,我們只需要在這其中選一個小的值記錄下來就可以了。

狀態轉移:

 dp[i][j]表示 第i到j字符之間爲迴文串的總花費

假設 str[i] == str[j] 第i和j處的字符相同,那麼我們只需往中間移動 ,因爲當前的花費爲0 dp[i][j] = dp[i+1][j - 1];

不相等的話 我們考慮在i - 1和 j + 1 的位置插入或者刪除(操作都一樣,後文統稱插入)一個字符

dp[i][j] = min(dp[i + 1][j] + w[str[i] - 'a'],dp[i][j - 1] + w[str[j] - 'a']); 在後面插入一個i字符+'i'字符的花費   在前面插入一個j字符+'j'字符的花費

到此狀態轉移就結束了.

我們的循環怎麼寫呢i的循序肯定是要逆序的 j要循序

因爲我們用到了 i+1和j-1的內容

#include <queue>
#include <cstdio>
#include <set>
#include <string>
#include <stack>
#include <cmath>
#include <climits>
#include <map>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stdio.h>
#include <ctype.h>
#define  LL long long
#define  ULL unsigned long long
#define mod 1000000007
#define INF 0x7ffffff
#define mem(a,b) memset(a,b,sizeof(a))
#define MODD(a,b) (((a%b)+b)%b)
#define maxn 2005
using namespace std;
const double eps = 1e-2;
int n,m;
int w[30];
int dp[maxn][maxn];
int main()
{
    char str[maxn];
    while(~scanf("%d%d",&m,&n)){
      scanf("%s",str + 1);
      mem(dp,0);
      mem(w,0);
      for(int i = 0; i < m; i++){
        char x[maxn];
        int a,b;
        scanf("%s%d%d",x,&a,&b);
        w[x[0] - 'a'] = min(a,b);
      }
      //for(int i = 1; i <= n; i++) dp[i][i] = 1;
      for(int j = 2; j <= n; j++){
        for(int i = j - 1; i >= 0; i--){
          if(str[i] == str[j]) dp[i][j] = dp[i + 1][j - 1];
          else dp[i][j] = min(dp[i + 1][j] + w[str[i] - 'a'],dp[i][j - 1] + w[str[j] - 'a']);
        }
      }
      printf("%d\n",dp[1][n]);
    }


    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章