杭電1698 Just a Hook(延時標記線段樹)

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.




Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
1
10
2
1 5 2
5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

Source
2008 “Sunline Cup” National Invitational Contest

 

 

題目大意:

T組數據,默認N個全是1(依次排列1~N均爲1),Q個操作,每次將從X到Y的數據變爲Z(Z=1,2,3)

解題思路:

線段樹的區間更新,用延時標記法。

AC代碼:

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn = 1e5 + 10;
int sum[maxn<<2];
int change[maxn<<2];
//void pushup(int i) {
//    sum[i] = sum[i<<1]+sum[i<<1|1];
//}
void pushdown(int id,int l, int r) { //延時標記    
    if(change[id]) {
        change[id<<1] = change[id];
        change[id<<1|1] = change[id];

        int mid = (l + r) >> 1;
        sum[id<<1] = (mid - l + 1)*change[id];
        sum[id<<1|1] = (r - mid) *change[id];

        change[id] = 0;
    }
    return;
}
void build(int id,int l, int r) {
    if(l == r) {
        sum[id] = 1;
        return;
    }
    int mid = (l + r) >> 1;
    build(id<<1,l,mid);
    build(id<<1|1,mid+1,r);
    sum[id] = sum[id<<1]+sum[id<<1|1];
    //pushup(i);
}
void update(int id,int l,int r,int x,int y,int v) {
    if(x<=l&&r<=y) {
        sum[id] = (r - l + 1)*v;
        change[id] = v;
        return;
    }
    int mid = (l + r) >>1;
    pushdown(id,l,r);
    if(x<=mid) update(id<<1,l,mid,x,y,v);
    if(y>mid) update(id<<1|1,mid+1,r,x,y,v);
    sum[id] = sum[id<<1]+sum[id<<1|1];
    //pushup(i);
}
int main() {
    int T, N, Q;
    scanf("%d",&T);
    for(int i = 1; i <= T; i++) {
        memset(change, 0, sizeof change);
        scanf("%d",&N);
        build(1,1,N);
        scanf("%d",&Q);
        while(Q--) {
            int x, y, z;
            scanf("%d%d%d",&x,&y,&z);
            update(1,1,N,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",i,sum[1]);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章