HDU1520 Anniversary party 树形dp

题目链接

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23856    Accepted Submission(s): 8418


 

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 

 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

 

 

Output

Output should contain the maximal sum of guests' ratings.

 

 

Sample Input


 

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

 

 

Sample Output


 

5

 

有根树上每个节点有一个权值,父节点与子节点只能选一个,问最大点权和。

树形dp基础题。

dp[u][1]表示选择u节点后子树最大点权和,dp[u][0]表示不选u后子树最大点权和。可以知道选父亲后儿子节点一定不能选,不选父亲时儿子可选可不选。

可以写出转移方程

v是u的子节点

dp[u][1]+=dp[v][0];

dp[u][0]+=max(dp[v][1],dp[v][0]);

 

#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#define ms(a,b) memset(a,b,sizeof(a))
using namespace std;
const int N=6e4+10;
int n,dp[N][2],v[N];
bool vis[N];
vector<int>tr[N];
void dfs(int u)
{
	dp[u][1]=v[u];
	dp[u][0]=0;//初始化
	for(int i=0;i<tr[u].size();i++)
	{
		int v=tr[u][i];
		dfs(v);
		dp[u][1]+=dp[v][0];
		dp[u][0]+=max(dp[v][0],dp[v][1]);
	}
}
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	while(cin>>n)
	{
		int l,k;
		for(int i=1;i<=n;i++)
		{
			cin>>v[i];
			tr[i].clear();
		}
		ms(vis,0);
		while(cin>>l>>k,l+k)
		{	
			tr[k].push_back(l);
			vis[l]=1;
		}
		for(int i=1;i<=n;i++)
			if(!vis[i])
			{
				dfs(i);
				cout<<max(dp[i][0],dp[i][1])<<endl;
				break;
			}
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章